Brakes on the car are working well except that the pedal clunks about one out fives times that it is pressed.  The clunk is not audible but can be felt by your foot.  Braking is normal as the clunk happens.  I can reproduce the clunk with the car running and parked thus it is not suspension related.  The master cylinder is new and uses an adapter like the one from Ipsco.  The booster is original and has not been rebuilt.  The pin connecting the pedal to the booster seems in good shape.  Does anyone have any insight on this?  Thanks

21

16

Attachments

Images (2)
Last edited by stevebuchanan
Original Post

Two things, when it clunks, first, does the pedal drop just a bit, but still feels firm and two, only happen when it's running, i.e. when the booster is charged?

I have a similar issue in another car ('74 Alfa 105). I rebuilt the calipers and replaced the master. Waiting on a new booster. I'll let you know.

I have only focused on the problem when the car running and the booster is charged with vacuum.

When the problem happens, the pedal clunks immediately and then works normally.

I ran the problem by Wilkinson this morning and we are thinking it could be the master cylinder spring not returning fast enough.  If so, it might be letting the booster's push rod (looks like an engine valve) drop out of the socket in the master cylinder.  Then when pedal is pressed, it finds the depression in the master cylinder socket (clunking into place) and works normally.

I have another new master cylinder (actually another rebuilt unit) and plan to swap it in and see if that fixes it.

I wondered about the same potential problem, the push rod not seating into it's receiver every time. Upon removal of the master i could see no evidence of such slippage. Checked under the dash to see if anything funny might be happening at the connection to the pedal. All appears in order.

I wondered next about an internal seal leak within the master, so that got renewed, but alas, no joy. I did notice though, that I could not reproduce the symptom unless the booster was charged, so that's next. In fact it arrived yesterday.

I'll know by the weekend.

A difficult problem to diagnose by long distance. I've seen such things caused by- for example- a loose front antisway bar that moves around when the car initially dips its nose on braking. I've also seen worn lower (rubber) shock bushings cause a clunk. It may not be tied to the brake pedal itself but to chassis motion up front. Look for signs of wear in things close to each other that shouldn't ever be touching.

Add Reply

Post
×
×
×
×
Link copied to your clipboard.
×