Skip to main content

Hi everyone,

I think I need help again.

Last year a friend and I overhauled the engine and among other things changed the old Duraspark Ignition to a Pertronix 3 ready-to-run Distributor.

At the time there was only the ignitor 2 coil available (thanks COVID), so I bought and installed it. The engine started fine and since this June it ran with no issues.

In June it started hardly and ran really bad at idle. In the first troubleshooting I found out it had a real weak spark.

Next time it wouldn't start at all, no spark. So I figured: Must be the coil, since I bought the wrong one in the first place.

From here on I started to chase my tail on and off the last 4 month.

- Changed coil 2 times

- bought and installed new battery

- checked if the rotor was even spinning and in the right position

- checked wiring and ground

- measured everything including the signal of the ignition with an oscilloscope (another friend of mine who is a car electrician did it) The only interesting result was there were only 9V at the coil during start. So we installed a cable from the battery directly to the coil and had perfect 12V (disconnected the original power supply of course and even the tach)--> still no spark

- finally I tried if there was a spark from the coil to the distributor and I couldn't believe it: with the direct connection to the battery the spark was so strong you could have welded with it.

- So I figured if everything works up to the distributor, the Ignitor 3 module must have gone bad. Ordered a new one and installed it last saturday and guess what: no f***ing spark...

I was so frustrated I had to close the garage door and walk away to avoid solving the problem with a hammer.

Now a week later I still have no clue what to do next.

If anybody has a good idea and can point me in the right direction I would really appreciate it.

As always. sorry for my bad english!

Original Post

Replies sorted oldest to newest


If the coil is producing a spark the Module is triggering the Coil just fine. The Module is Not the problem.

Hot spark is Getting "to the Distributor"...where is there NO Spark, Found?? At the Delivery to the Distributor CAP from the Rotor?  Check Center contact TO Rotor.

Check Rotor and Cap, Contacts...and be advised the 'Little' graphite Spring-Loaded Contact, Inside the Cap...Dead Centered...Likes to Break-Off!! NO Spark to the Rotor, and NO spark to cap, to be D-I-S-T-R-I-B-U-T-E-D to the Plug Wires/Spark Plugs.

I've have found (2) that broke-off! One Center contact broke off while I was Just Installing a Brand-New Distributor Cap, onto a Unilite!! And we know how expensive those Caps are.



Warning: When testing Coil firing, be sure there is a ground to fire TO! If the high tension Wire should be left 'Open', or 'Just' testing with Too Large a GAP, the Coil will fire upon itself Internally. This may Burn a Pathway through the wiring, that will be a 'Short-Cut' for the High Voltage to the 'Internal' Ground side of the Primary, from that point forward, a Pathway. Many a 'Brand-New' Coil has been ruined, by Inexperienced 'Testing' on the workbench! Now we Know. Always Use a Properly gapped Spark-Plug, to test a Coil, and make sure it's Grounded.

Last edited by marlinjack

Add Reply

Link copied to your clipboard.