Speedometer making noise & the needle is jumping

Hello all,

My speedo needle has been jumping and making noise since I bought the car in 2017.  In a quest to fix it my mechanic put in a new gear last year (Borletti 50-0806), and I recently put in a new cable supplied by Wilkinson (I previously tried lubing the old one but that didn’t help).   I ran the new one through the same path as the old one (see pix), though it seems slightly longer.  Still not working.  It seems like the only thing left would be the speedo itself, but from the threads I’ve read the bouncing needle doesn’t usually seem to mean the speedo’s broken.  Any suggestions?

Thanks,

Timspeedo cable path interior_editedspeedo cable path under_edited

Attachments

Photos (2)
Original Post

Your cable jacket install looks good with nice big sweeping turns. It may well be your speedo; the simplest way to check is to borrow a known-good instrument from another owner, hook it up and drive a ways. It need not be put in the dash for this. Pantera and Mangusta speedos of the same ratio are interchangeable and have green ink-lettering on the case back to denote the ratio. There are two ratios and two different cable connector threads, so 4 possibilities.

The right-angle ZF speedo adapter is tricky to install: the dual-thread nut must be screwed all the way up the adapter body, then installed by screwing it down until things bottom lightly on the ZF drive. If the adapter is not installed this way, the system can drive off the extreme tips of the fork-adapter in the assembly and will often break one side of the fork, over time. Over-tightening the nut does nothing except make one tired. Sealing to prevent tranny lube leaks is done by an o-ring in the assembly, not the tightness of the nut.

45-yr-old NOS right-angle adapters normally contain brick-dust that once was lubricant and are not made to be service-able. Note also that if an expensive right-angle adapter is actually broken, they're often repairable. I've fixed more than a dozen over the years with various ailments.

Thanks Bosswrench.  Cold weather has moved in in Boston, so I may not be able to get it on the road for quite a while.  I was wondering if it makes sense to spin the cable with a drill (from the back end) to see if that moves the speedometer in a normal fashion.  If that fails wouldn't that show it's a malfunctioning speedo?

 

My car had a similar problem when I first got it.  It seems that the PO took the over tightening of the adapter nut to an extreme, and bent the tang on the end of the drive pinion shaft.  Hopefully this is not your situation, but worth a look if all else fails.

Add Reply

Likes (0)
×
×
×
×