Skip to main content

Have tried to remove the subject coupling using the procedure outlined in Pantera Place without success.  Let it soak overnight in PB Blaster and managed to get it to move past the undercut so there is only ~ 1/4 inch of spline left.  At that point it would not move so I used a pickle fork to get more load on it.  Hit with the pickle fork with a hammer but it would not budge. I am concerned that I may damage some steering shaft internals if I really beat on it.  Any suggestions would be greatly appreciated.

Original Post

Replies sorted oldest to newest

This might work for you. Gather several open end wrenches just large enough to slide over the shaft.

One and hopefully two wrenches will fit and you can use them to pry against each other in the hopes of getting some movement.

I have successfully used this method to disconnect a stubborn U joint back at the ZF selector housing.


Thanks for the feedback and sorry for the delay in responding.  Larry, tried your suggestion and it didn't help but a good idea that I may use in the future.  Husker, there were no burrs and the splines were not rusted.  Joules, the bolt was removed in all attempts to remove the coupler.  Tried to loosen the lower u-joint and it would not budge.  Larry Stock suggest loosening the steering rack which worked immediately and he also recommended reassembly with the rack loose.  Thanks again for your suggestions and thanks to George for this invaluable site.

Add Reply

Link copied to your clipboard.