Ugh, hats off to those with stock Panteras that can mostly just hop in the car and drive. But still the extre gizmos & such on modified cars are fun (when they work). Anyway, I posted here a few years ago about my suspension problem where we found it was this switch discussed in the link below that was not working well to allow the compressor to uptake air to the supply tank:
http://pantera.infopop.cc/eve/...581040936#6581040936

But now I am having issues that I am thinking may be something else. This time I turned the car on with my on/off kill switch as usual in the front trunk and I heard the air compressor operate right away for about a half minute (as it typically does sometimes if I have let the car sit a while). So to me it seems this switch in the discussion above is doing its job to get air to the reserve tank and shut off. I believe that is all this switch does in the discussion in the link above (fills the reserve tank with air automatically then shutts off).

But this time when I press the up switch to raise the car, the car will not raise up. This valve unit below is also part of the Ridetech system. So this time I am at a loss what to test. Even if I knew what to check, its almost impossible to get at from above due to it being so deep under the car, and going under the front of the car, well thats slammed almost to the ground. These photos were taken before when I had a chance to raise the car. Upside is that I like looking at the car sitting there in the garage. Anyone here have experience with these systems or what I may look for to test?

AirRide by JanDaMan, on Flickr
AirRide by JanDaMan, on Flickr
AirRide by JanDaMan, on Flickr
Original Post
quote:
Originally posted by Hemihunter:
Just tap the solinoid lightly with hammer, if it works then i suggest its dirt in the system, i would strip and clean the solinod valve body, and at that point add a in line filter after the air tank before the solinods to keep any dirt out.

Thanks, I think you're right. I found this link on youtube below that explains what this unit does & how to service it. Once my garage gets under 110 I will attempt to take a closer look from above and see if I can reach down there to give a tap with hammer, wrench or whatever I can fit.
https://www.youtube.com/watch?v=GHVYSgVhjqs
Ugh, still digging into this trying to find the issue. Hot humid weather in a garage sure don't make it any more pleasant. Been touching base with Ridetech too. It seems my valve block was set up where only one coil & one line is piped to raise the car as shown below. It appears coil #1 shown in the photo is the only one to raise the car and coil #2 just sits there with no function. After much bleeding hands working from above I was able to switch coil 1 & 2 and in doing so I now definitely hear a click in the valve block when I operate the switch to raise the car. But WTF the car will still not raise up. The wife pressed the up button while I felt the coil & valve block but I could still not tell by feel which coil was clicking. There's definitely air pressure in the tank because when I clicked the car on the compressor worked to fill the tank for about a minute and then shut off (like it should). I even went back in to try and take the valve stem out of location #1 like it shows in this link below. Got the coil off easily, but it aint as easy as it shows in the video link below to remove the valve stem due to it being on so tight! Screwdriver on the top in close quarters doesn't work well at all, then I tried to double nut it and that didn't work well since the threads on the valve stem are not very long for 2 nuts. Then vice grip without room to work didn't go well either. I may try and grind down a couple nuts to fit on the valve stem better and try the double nut method again. I just wish I knew which coil was clicking, or maybe both are. Anyway, what a stinking delema. I don't know how you guys have patience with these cars. I may end up trying to sell all 3 at once as I am finding 8 cars are eating up my entire life. Nice cars are such love/hate, almost like the ex-wife.

Ridetech video showing how to service the valve block:
https://www.youtube.com/watch?v=GHVYSgVhjqs

IMG_2364Ridetech by JanDaMan, on Flickr
The way it normally works is one valve puts air into the shock and one valve releases air front the shock. That is why there are 4 valves. 2 per shock, someone got lazy and just plumbed both to one set of valves. The problem with that is when you corner hard, air gets pushed from the shock under load to the shock not under load making the car lean, instead of stay flat in the corners. You really should fix that once you figure out the valve problem.

If there is no air in the shock and you hear clicking but no air noise, you may be energizing the valve that releases air from the shock, since there isn't any air in the shock it seams like nothing is happening when in fact, it is working correctly. Because you are not using 3 & 4, you could move to those valves. Do you have clicking when you press up as well as down? One valve should click when you press up and one should click when you press down. If the up isn't clicking then you have found the problem. There are also many ways to troubleshoot this like moving the airlines around, moving the switches around so up is down and down is up, etc... hope this helps a little...
Thanks for the info. Initially the car wouldn’t raise & no click noise at the value block but the car would lower fine with click at the valve block. Then I switched coil 1 & 2 because looking at the photos above these two look like they are on the supply side of the block to let air in and 3 & 4 look like they are on the exhaust side to let air out. So now I hear a click at the valve block when I press the up button but the car doesn’t raise up. Looking at the video link I assume the click I hear is the sound of the valve opening when I activate the coil (not the coil itself making the click). I have the coil in the #1 spot removed from the valve stem right now and am wondering if I could try the up switch with the coil just sitting there? That would leave the intake coil in place at the #2 spot. Then if I hear a click I assume the coil at the #2 spot works. If I could get #2 off again I could remove that and leave #1 in place too. Would it be safe to operate the switch with a coil removed from the stem but still getting current from the switch?
If you want to get the car raised quickly you can move the black supply line and connect it directly to the tee. Then turn the pump on until it gets to the height you want.

For troubleshooting, I would move air lines around rather than taking solenoid and valves apart until you identify which is the problem.

You could put air pressure on the exhaust port (the open port) and then energize the down solenoid and the shocks should raise instead of go down. The valve block should be very easy to test with air pressure and the switch assembly so you can operating any one of the 4 valves. Since you have 2 extra you could move the air lines to the unused 2 & 4 valves. 2 to raise, 4 to lower. Does your switch assembly control all four solenoids even though your only using 2?

You may find it easier to troubleshoot if you remove it from the car and bench test it. If you simply want to raise the car to move it, just move the supply air line to the tee and pump the shocks up.
Problem is that I can only get to the valve box from above, and even that is pretty limited for space. So I can’t reach the supply or delivery hoses. But I understand that the coils operate like a magnet when the up or down switch is pressed, so I am thinking to place a piece of metal to the outside of each coil while the wife operates the switch & feel for a magnet pull. Looking at the photo I am thinking #1 on the valve block is the coil & valve that should be working to raise the car. It seems #2 is probably the other port to raise the car, but that part of the block looks to be plugged for supplying air. I am thinking if #1 has a magnetic charge but the car still doesn’t raise, then I would pull that valve stem with the theory that valve isn’t functioning right (may be stuck). With the valve stem out I could clean that area the best I could with a few shots of air & replace with a new valve stem. At least that would rule out #1 coil & # 1 valve, no? Wife’s at knittin right now, so I just sit & eat chips with beer till then. All the better since it’s over 100 in the garage now, meaning more beer.
Well it seems the coils don't give off a magnetic force on the outside of the coil because I didn't get any pull from any coil when my wife worked the switch and I held a screwdriver to each; although I heard the coils click. I removed the coil in spot #1 and still heard a coil clicking on the block when she was working the up switch, so I presume the coil in location #2 was clicking (but of course will not raise the car since it isn't fixed up for air from the block to the air bags). I think I will just take out the valve stem from #1 and get a new one. After I have that valve out and then turn the car on I believe that air from filling the tank should just shoot through that empty valve block area to clean it up. Then I could put the new valve in and see if it all works.

No, can't get a floor jack under the car as it sits about 1" off the ground. I could maneuver to maybe get some ramps to help with a little more clearance height but I hear just using one jack on the side of the car may result in the flush mount windshield to pop out. But if needed I think I could eventually work something there if needed to get under.

Looks like all the custom stuff coming back to haunt me. If it comes down to it, I will just let the car sit in the garage permanently and just start it on occasion. At least then I can just look at it and drive the reliable Lambo LP640 instead.
quote:
Originally posted by over50:
You might try to get some of the jacks that have two arms that go under the tire and lift up the wheel. With two of these jacks you could pick up the front or rear without twisting the body.

Thanks but looks like those jacks only raise the car by maybe a couple inches from what I see anyway. I suppose if I really need to get under the car I could use my wifes 100s of Martha Stewart magazines to build a gradual ramp to then get a jack on each side of the car to get some jack stands under the frame. But at least I was able to determine if both #1 & #2 coils are good by hearing a click when hooking up either #1 coil or #2 coil on #2 valve stem and then press the up button. Of course the car won't raise since that valve stem air goes to nothing. Then neither #1 or #2 coil created a click when I hooked those up to #1 valve stem. So to me it seems something is wrong with #1 valve stem components or an air blockage. Best now I can do is try and get #1 valve stem out and take a look. But that bitch is turned into the block so tight I have to grind down a couple nuts and try and double nut it out rather than a useless screwdriver to the top. But of course now the weather is crap to mess with all this. So much for Southern CA paradise: high heat, high humidity, high taxes, but at least there's plenty of thongs at the beach and lotsa massage parlors on every corner just like Starbucks.

Next step (although block not removed from the car):
https://www.youtube.com/watch?v=GHVYSgVhjqs
quote:
Originally posted by over50:
These on Ebay say they lift over 4".

https://www.ebay.com/itm/1pair...c&_trksid=m570.l1313

How cool! Thanks for the tire lift info. Never knew anything like that existed. What a pain with this air shock stuff, but I was finally able to get the valve stem out of the valve block by using some WD40 on the thread area over night and then trying double nut on the top of the valve stem again. Here are some photos of the valve stem & plunger assembly. They tell me that the rubber part of the plunger should be flat and not irregular surface like mine shows. So maybe mine was sticking due to that. While I wait for that part with plunger & spring to arrive I am thinking of running the cars air compressor in an attempt to blow out any debris that may be in the line or in the block going to that valve area. If I do that, air should just blow out this open area of the block noted in red right?

IMG_2116RideProRidetechValveStem by JanDaMan, on Flickr
IMG_2124RideProRidetechValve by JanDaMan, on Flickr
IMG_2114RideProRidetechValveBlock by JanDaMan, on Flickr

Plunger should look flat like this:
https://www.ridetech.com/produ...r-round-silver-coil/

Ridetech video showing how to service the block:
https://www.ridetech.com/info/...010/12/100_23842.jpg
Well finally resolved & back in business. As suspected the problem was this $15 valve. As noted in the post above the rubber part of the valve became distorted over time and therefore stuck into the valve block. In this photo below of the new valve the rubber part is flat so it easily lifts out of the valve block when I press the up button. Amazing how a $15 part can disable the entire car so I bought 2 just to have a spare handy. Thanks for everyone that chimed in.

IMG_2472RideProValve by JanDaMan, on Flickr
quote:
Originally posted by Hemihunter:
looking at your pics seems like alot of oil in the system as well, or could it be water? like i said before add a filter on the discharge side of the compressor. Glad you got it sorted.

Thanks, I will think about a filter too. I see Ridetech doesn't sell them with their units, so I am asking them why. As far as it looking dirty or oily, remember I squirted some WD40 to help release that valve stem so that's all that shiny stuff is. When I took my MBZ SL65 into the shop last week I also saw they had some nice low profile and very light weight ramps sitting there. So, am going to get some of them too. Looks like they come in 2&1/2" for the "Scale Ramps" and a 3" version too. I actually made some out of wood a few years ago, but heavy as heck and once I had my 5S rear tire hook up with one of the ramps and it threw it to the side almost hitting my Lambo! Ha ha Pantera throwing things a the Lambo!

https://raceramps.com/ramp-cat...e-and-service-ramps/

Ramps by JanDaMan, on Flickr
Ramps by JanDaMan, on Flickr
quote:
Originally posted by George P:
Jan you're 'da man.

Glad the problem is resolved. I hope all is well, wishing you the best.

Thanks. Things would be more fun to tinker with if the weather was cooler! Everyone is always helpful here & I guess that's the process of learning as long as I don't make things worse in the process of fixing, haha. It seems Ridetech doesn't put in-line filters in their systems; however there is a sandwich intake filter where the air is sucked in by the compressor where I found the outer dark foam portion was crumbling apart but the inner white filter looked pretty good. So I just need to get some foam & cut to size to replace that outer piece. Probably just some AC foam from Lowes or vacuum cleaner foam that I can cut down to 1 & 1/4" diameter.

IMG_2423RidetechCompressor by JanDaMan, on Flickr
IMG_2665RidetechFilter by JanDaMan, on Flickr

Add Reply

Likes (0)
Post
×
×
×
×