Team some help please. My temp. measuring point is AT THE Block/Waterpump. Not at the swivel tank.

Running the car at outside app 23 C = 75F  the gauge did show guessed 90 C  = 194 F (is a European gauge, so one notch up over 160 F )

Anyone with experience on Temp readings for this modified location please???

TX

Matthias

Original Post

Hi Matthias-

If that’s the real (accurate) temp, it sounds like you are right on the money. 

190 is hot enough to keep the oil heated correctly, and below the boiling point of the coolant. 

If the temp stabilized there, you should be in fine shape. 

What thermostat (type & temperature rating) are you running?

Regards -

Chuck

P.s. My capillary mechanical gauge sender is there, and my gauge consistently reads about 180. 

Last edited by rocky

Chuck TX , Team!

Thermostat is RT 310, 

Fluydine cooler all according George P recom.

- smaller water pump pully for more ref..
- Edelbrock high volum water pump
- heating pipes stubbbed
- Fans are running, correctly 
- Radiator swicht need to find the data, but per George's advise to balance between Thermostat and On/off radiator switch
- NO air in system..got bleeded again and again..(Tx Jack's hint), stable now..1 bouble max at radiator
- is still the old modle set up with overflow tank..correct lits applied

As I now measure RIGHT at the hotest spot was wondering for REFERENCE..Temp readings.

(the cat was running at 180 km/hour for a while ok..think 3800 rpm..), (will next use my temp hand held device to confirme..the Italien gauge precision readings)



  

Attachments

Images (1)
Last edited by matg

Add Reply

Post
×
×
×
×
Link copied to your clipboard.
×